Library Update - VPDSS v2.0

Another new addition to the Alyne Content Library - the Victorian Protective Data Security Standards (VPDSS) V2.0.

Another new addition to the Alyne Content Library - the Victorian Protective Data Security Standards (VPDSS) V2.0.

The VPDSS V2.0 establishes 12 high level mandatory requirements to protect public sector information across all security areas including governance, information, personnel, Information Communications Technology (ICT) and physical security.

The new content includes a VPDSS V2.0 2019 Control Set containing 277 Controls. This will certainly seek to benefit organisations in the Victorian public sector in assessing the current maturity of their security management of public sector information as required by the Office of the Victorian Information Commissioner. The timely deployment of this Control Set also allows organisations to be well prepared for their next VPDSS V2.0 regulatory reporting cycle in June 2020.

As with all library updates, this standard has been provided to existing and new Alyne customers alike.

Contact Jeff Sussman at jeff@alyne.com to find out how Alyne can help your organisation, or request information about how you can experience Alyne’s capabilities in a Proof of Concept.

ZurückWeiter
Jeff Sussman

Related Posts

Blog thumbnail

Library Update: EBA Guidelines under SREP

The latest deployment to our Content Library - the European Banking Authority Guidelines on ICT Risk Assessment under the Supervisory Review and Evaluation process (EBA/GL/2017/05).